Home 
Home Search search Menu menu Not logged in - Login | Register
> mcguan.2

Profile Topics Posts
Posts by mcguan.2
42 postsShowing posts 1-40 of 42

Carburetors > Sluggish acceleration (9 replies - 5298 views)

Thanks for the help, guys. I pulled the top off the rear carb to check the float level and when I was rocking it ...   04-09-2015 06:02 pm

Carburetors > Sluggish acceleration (9 replies - 5298 views)

Brett Gibson JH5 20497 wrote: I'm thinking you need to start at the beginning and make sure that your ignition, timing, plugs, wires, compression etc are ...   02-28-2015 12:23 am

Ignition > Static Timing Questions (9 replies - 4670 views)

Figured it out. The clip had closed itself down and was keeping the distributor from being able to push all the way in. I ...   02-15-2015 12:14 am

Ignition > Static Timing Questions (9 replies - 4670 views)

So upon removing the distributor cap, I see it is petronix, and the rotor inside just freely rotates, so I set about trying to re-seat ...   02-14-2015 08:52 pm

Ignition > Static Timing Questions (9 replies - 4670 views)

Unfortunately, my mechanically-inclined friend (and JH owner) moved to Vancouver a couple years back, so I'm on my own. I think I misspoke when ...   01-26-2015 05:02 am

Ignition > Static Timing Questions (9 replies - 4670 views)

Wow. This is exactly the type of step by step instructions I need. I would consider myself a novice mechanic at best. ...   01-25-2015 01:41 am

Ignition > Static Timing Questions (9 replies - 4670 views)

I found one of Mark Rosenblum's old posts regarding removing the distributor and setting a rough static timing, but there are a couple things I ...   01-19-2015 01:54 am

Ignition > Static Timing Questions (9 replies - 4670 views)

I moved this topic from the carburetor section because, based on y'all's advice, I've been tackling ground and timing before moving into carburetors. 11609 sat ...   01-18-2015 09:54 pm

Carburetors > Sluggish acceleration (9 replies - 5298 views)

I'm going to try and tackle checking the timing tomorrow, but having never done that before (on any vehicle) I'm open to tips. I've ...   01-17-2015 11:51 pm

Carburetors > Sluggish acceleration (9 replies - 5298 views)

Thanks for the suggestions. It's really hard to actually *see* down in under the distrib cap, let alone actually get it off because of ...   01-04-2015 10:40 pm

Carburetors > Sluggish acceleration (9 replies - 5298 views)

So, I had 11609 under a cover for about a month due to all the rain in the Bay Area. When the weather finally ...   12-29-2014 12:41 am

Engine & Transmission > 4-speed Gearshift Linkage Question (4 replies - 3546 views)

Thanks, Jim. My manual only shows a 5-speed schematic, but the one on the Delta site is helpful. It looks as though part ...   06-05-2013 03:06 am

Engine & Transmission > 4-speed Gearshift Linkage Question (4 replies - 3546 views)

A little while back, I was having a lot of difficulty getting the gear shift lever to find gears. It felt like the transmission ...   06-04-2013 07:34 pm

Carburetors > Dellorto Filters? (7 replies - 6401 views)

OK, thanks Greg. And from what I've seen in the forum, 40mm is the length I would want? ...   04-20-2012 10:20 pm

Carburetors > Dellorto Filters? (7 replies - 6401 views)

I'm installing Dellorto DHLA 40's on 11609 and I'm looking for advice on filters. I've seen/heard of different setups. If I get K&N ...   04-20-2012 08:42 pm

Brakes > Mushy brakes (30 replies - 20364 views)

It's really hard to tell what color the fluid is because it's not coming out in copious amounts, just seeping out. I've been driving ...   06-26-2011 12:40 am

Brakes > Mushy brakes (30 replies - 20364 views)

Greg, understood, but wouldn't it be strange for a brand new MC (purchased from the club store) to start leaking within minutes of installing?  I ...   05-28-2011 09:09 pm

Brakes > Mushy brakes (30 replies - 20364 views)

OK, so I installed the new master cylinder (the TR6 model) and changed over the brake fluid to DOT 5.  However, I'm still getting a ...   05-28-2011 02:08 am

Brakes > Mushy brakes (30 replies - 20364 views)

Jody, Any particular brand of DOT 5 fluid I should use?  Also, what's the capacity of the system, i.e. how much should I buy? ...   05-18-2011 05:58 pm

Brakes > Mushy brakes (30 replies - 20364 views)

Thanks for the help, Jody. I'm not especially concerned with keeping my car original, so the TR6 should work for me. Sure, you ...   01-20-2011 06:26 pm

Brakes > Mushy brakes (30 replies - 20364 views)

Jody,  I have a Jensen Healey MC, at least according to one of the old posts on the forum. Also, take it easy on me here, ...   01-19-2011 03:04 am

Brakes > Mushy brakes (30 replies - 20364 views)

I pulled the master cylinder and it looks like the bore is pretty corroded, so I'm thinking of getting a new or rebuilt one from ...   01-18-2011 02:56 am

Brakes > Mushy brakes (30 replies - 20364 views)

Thanks for the tip.  It *does* appear that there is seepage between the MC and the booster, but not a lot, so it wasn't too ...   01-05-2011 06:11 pm

Brakes > Mushy brakes (30 replies - 20364 views)

About a week ago, my brakes started getting really mushy and the pedal was going down to the floor on some stops.  I put it ...   01-05-2011 12:00 am

Electrical & Instruments > Speedometer cable connection on tranny side (1 reply - 3934 views)

When I was taking out the instrument cluster the other week, I had to pull a bit on it to get it far enough out ...   05-19-2010 03:48 am

Electrical & Instruments > Removal of instrument panel (6 replies - 4529 views)

Thanks for all the suggestions, guys. I've installed a new tach off my parts car, cleaned the connections, etc, and the tach works fine, ...   04-26-2010 04:15 am

Electrical & Instruments > Removal of instrument panel (6 replies - 4529 views)

Thanks for the help, fellas.  I'll get started on cleaning the connections right away. ...   04-22-2010 10:33 pm

Electrical & Instruments > Removal of instrument panel (6 replies - 4529 views)

Recently my tachometer stopped working in my '73 mkI.  Reading a bunch of stuff on the forum, I decided that I might want to pull ...   04-21-2010 10:38 pm

Electrical & Instruments > Alternator voltage randomly jumps (1 reply - 2523 views)

Driving a while back, I noticed that my voltage meter was in the red, so I parked the car and didn't get to really check ...   03-16-2010 01:32 am

Electrical & Instruments > Alternator voltage seems high (3 replies - 3492 views)

Just today, I started experiencing a similar problem.  I had the alternator rebuilt about 8 months ago, and it always registered a little high on ...   03-04-2010 10:56 pm

Fuel Stuff > Engine not receiving fuel (4 replies - 5390 views)

Funny you mention that.  I got out the multimeter and checked the voltage at the pump.  Nothing.  So, I opened the hood to nose around ...   01-27-2010 02:27 am

Fuel Stuff > Engine not receiving fuel (4 replies - 5390 views)

The tank was replaced by previous owner.  It's probably a good idea to check the filter anyway, but when I turn the key I don't ...   01-26-2010 06:19 pm

Fuel Stuff > Engine not receiving fuel (4 replies - 5390 views)

Yesterday, on my way to work, my '73 started stalling at stop signs.  I thought, well this isn't good, and tried to get back to ...   01-26-2010 05:14 pm

Electrical & Instruments > Electric fan always running (2 replies - 3023 views)

The electric fan that cools the radiator on my '73 has started running all the time when the key is in the on position.  The ...   01-25-2010 06:27 pm

Body & interior stuff > Door rattle (6 replies - 4099 views)

Thanks for the heads up.  I'll look into all this.  One more thing, on the interior weatherstrips, they sit on a long "bracket" that is ...   05-12-2009 08:49 pm

Body & interior stuff > Door rattle (6 replies - 4099 views)

I have a '73 Jensen that I recently brought back to life after sitting for a year and a half.  It's driving pretty well, so ...   05-12-2009 06:51 pm

Engine & Transmission > Oil spewing out below carb (5 replies - 4773 views)

Thanks for all the help, fellas.  That's what it was -- the oil pressure fitting that feeds back to the pressure gauge.  It had in ...   03-09-2009 05:40 pm

Engine & Transmission > Oil spewing out below carb (5 replies - 4773 views)

Thanks for the help. It must be a mkI. There's no engine oil filler on either cam cover; it's in a different spot. My concern ...   03-08-2009 07:40 pm

Engine & Transmission > Oil spewing out below carb (5 replies - 4773 views)

I just bought a '73 Jensen that had not run in over a year. After rebuilding the carbs, changing the fuel in the tank, ...   03-08-2009 06:31 pm

Electrical & Instruments > Meltdown! (1 reply - 3053 views)

OK, so I hooked up my rebuilt alternator on my '76 GT and then went to hook up the battery.  I hooked up the negative ...   02-18-2008 03:59 am


 Current time is 11:48 pm
   1  2  Next Page Last Page


UltraBB 1.172 Copyright © 2007-2011 Data 1 Systems