Home 
Home Search search Menu menu Not logged in - Login | Register
> Jensen Healey & Jensen GT Tech > Projects > 1973 Jensen Healey #10777 Lotus "Colin Chapman" Edition "Gold Leaf" Build

 Moderated by: Greg Fletcher Page:    1  2  3  Next Page Last Page  
New Topic Reply Printer Friendly
1973 Jensen Healey #10777 Lotus "Colin Chapman" Edition "Gold Leaf" Build  Rate Topic 
AuthorPost
 Posted: 02-11-2020 04:19 am
  PM Quote Reply
1st Post
discogodfather
Member


Joined: 09-17-2007
Location: San Francisco, California USA
Posts: 155
Status: 
Offline
This is a build and customization thread of my JH, kind of an organization of the project and it's timeline. After nearly 12 years sitting, getting it back on the road.

PART 1: The Background

Around 2000 or so I had a friend in college who owned an 87 Lotus Turbo Esprit. He was technical but not a mechanic and I had the amateur mechanics / fabricator background and was in school for mechanical engineering at the time. I had done tons of work with Porsches of that period but the Esprit was my first foray into English material, and I immediately fell in love with the Lotus engine. After I successfully diagnosed a problem with the KE-Jetronic (from my Porsche experience) I got a green light to work on the car. It was a marvelous machine and at the time was affordable, at least by today's standards.

But it wasn't affordable from a college kid top ramen budget. I realized I couldn't afford anything heading into graduate school but I had a good job at the university working as a research assistant, and I managed to save a bit. Turbo Esprit was out of the question but maybe an old S1 or S2? I almost closed a deal for 9k for a non-running S2, but it got away from me. I started to read about Lotus and realized the engine started in the JH in the form of the 907.

In 2005 I purchased this highly customized 73 Healey from a local builder (in the Bay Area). He had been restoring cars and planes for years, and had real taste and I immediately fell in love with the car. I remember pulling up to the parking lot where I first saw it and next to it was a 66 Shelby GT-350 the same builder had just completed. I think the first time I opened the throttle I yelled "sold!" right away. For $6500 it was a damn good deal.

The car was chassis number #10777 from late 73' (just found this out from the board here) and it had a highly built 74' engine. Some of the list of extensive mods and custom fab:

Engine: 2.0 Liter custom cam, carillo rods, stainless exhaust valves (oversize), knife crank, high comp pistons, twin weber DCOE 45's, custom headers, head ported and polished, velocity stacks. 190hp at the crank, 2.5" custom free flow exhaust to the tips (no cat, minimal muffler)

Trans: Getrag 5 speed rebuilt

Body: Custom chrome moly roll bar, custom flared steel fenders (all metal), custom springs (lowered), Koni inserts, lots of custom stainless steel pieces including the bumpers, bigger sway bars, all poly urethane bushings, fiberglass hood (from Delta I think). Aluminum Turbine wheels (I believe made by Western wheels) at 13x7 front and 13x8 rear, 225 and 235 radial TA comp tires. Lecarra steering wheel.

The original idea of the build was to make a kind of "what if Colin Chapman did a custom edition of the JH". The builder had been in his 20's in that time period and loved the Gold Leaf Lotus Formula 1 stuff from 1986-1971 ( the Lotus 49 and 72, etc.) and did the car in that color red with some gold pinstripes at the sills and gold accents on the wheels.

Car as it appeared when I first saw it:




Back To Top PM Quote Reply  

 Posted: 02-11-2020 04:40 am
  PM Quote Reply
2nd Post
discogodfather
Member


Joined: 09-17-2007
Location: San Francisco, California USA
Posts: 155
Status: 
Offline
PART II: Living with it and Mods

The car was a masterpiece and I didn't really want to change anything, but reality started to change things regardless. Right off the bat I had a big problem: the tires. Since the wheel wells had been flared out I essentially had to run fairly wide wheels to make any sense of it. The builder had used a custom set of very era popular western turbine wheels, and they were glorious. I loved the look, but the first issue was tires. At the time BF Comp T/A's were still being made, and they had a decent rep as a good street tire and all arounder that lasted. They had sizes in 225 up to and amazing 255 and were very low profile, if I remember correctly around 40.

BF Goodrich promptly discontinued the tires in these 13 inch sizes. As if they heard I bought this car, lol! I ended up having literally zero options for the size unless I wanted to step up to some massive profiles. Sure there were tons of R1 compound and racinf tires, but that wasn't going to cut it where I live in the rain and bad roads. My tires balded as I kept looking for an alternative.

But then things got worse: wheel problems. I had some shaking issues at around 55mph, but thought it was a balancing problem. I remember the builder saying that the wheels were actually not the correct 4x4" or 4x101.6mm pattern. They had been modified (maybe from a 4"x95mm or a 4"x104.5mm, I can't remember. I had the wheels balanced and the problem didn't go away. I was flying down 280 south one day to San Jose at some kind of *legal* speed, and I got a violent shaking of the steering wheel, real bad. I thought I had blown up a tie rod, it was that bad.

The front passengers side wheel had come loose and was damaged - holes rounded out and ovaled with lots of metal missing, including some damage to the spindle and the studs. Towed home and pulled all the wheels and found some ovaling on all the wheel holes, and realized the bolt pattern issue had caught up to me. Big bummer.

I replaced all the bearings and the front spindle on the passengers side, and looked for some replacement wheels. I thought maybe some mini-lites or something in that vein, but nothing really presented itself. Most were around 7" and I started to do all the permutations on which tire would fit, etc. I ended up not being able to find anything close to the deep inset I needed (or small backspace for Americans). I ended up going with a stamped steel wheel out of frustration with finding a good street tire/wheel combination. Final setup was a Diamond Racing wheel at 15x9 in the rear and 15x7 in the front. Cooper cobra 225 / 55's.

The look was odd. It kind of reminded me of a dune buggy and the wheels filled every damn MM of the wells and it did rub a bit on hard turns. Miraculously didn't touch in the rear. But they were way too big, I went from rims that were around 12lbs with a 19lbs tire to a 19 lbs rim and a 24 lbs tire, big mistake. It was grippy as hell but it plodded along, gone was the steering response. It also raised the car about 2" so it looked like it was floating in air. Monster truck??


Back To Top PM Quote Reply

 Posted: 02-11-2020 04:47 am
  PM Quote Reply
3rd Post
discogodfather
Member


Joined: 09-17-2007
Location: San Francisco, California USA
Posts: 155
Status: 
Offline
PART III: More Mods and taking it off the road

The wheel issues were at least passable for the time being, so things were going ok, despite the looks and the loss of some nice handling perks. The engine was doing great except for a bit of carb popping when I decelerated.

I started to mess with Velocity stacks, as the original setup was that kind of dual K&N filter. I bought some short stacks and had some filter covers made (there used to be a guy on ebay selling some custom made ones) and I ended up moving out to a very long configuration. This helped with mid range torque and the flat spot at the carbs. It sounded heavenly.

The engine cira 2008:



Back To Top PM Quote Reply  

 Posted: 02-11-2020 05:12 am
  PM Quote Reply
4th Post
discogodfather
Member


Joined: 09-17-2007
Location: San Francisco, California USA
Posts: 155
Status: 
Offline
PART IV: More Life and the Takedown

Started to travel more for work and ended up leaving her with a friend who had a garage when I moved to a new place that didn't have one. The plan originally was just to have her set there for a bit while I finished some extended trips. Disaster: friend left her out in the rain one night. I had a nicely made top on her at the time but it rained and it leaked pretty bad. He did this for a few days, then put her back in the garage when I yelled at him.

When I got back from the trip it was damp inside. I was furious and pulled the mats to discover some nice surface rust formed over the weeks it was sitting in the water. I ended up pulling the entire floor mats and spending ridiculous hours media blasting, grinding, and prepping the floors and then putting down some heavy epoxy paint. It was again 100% rust free. This process took weeks for me working very part time as real world work was extremely heavy.

Moved to a JHPS 4 piston front setup and rebuilt the entire brake system in late 2008. Went to a Petronix Ignitor instead of points, still endlessly messing with that decel popping problem.

Coming back from a Sharks game in 2008 with a friend we achieved a hella of a speed coming back on 280 north! No rev limiter and this thing was pushing max rpms, a nice little treat (of course at legal :) speeds).

All of a sudden carb popping was worse. I had eliminated the ballast resistor and went to a Petronix coil. I suspected ignition, but wasn't particularly knowledgeable and messed with it in bad ways, reversing polarity by mistake and leaving the ignition on without the car running. I believe that to the problem now, but at the time I was unsure and started to think carbs.

I ended up rebuilding the carbs, Italian DCOE 45's. I felt like the accelerator pump piston might be worn but I really didn't know better, and started to think - maybe I should just get new carbs. Ended up selling the Italians and got a new pair of Spanish Webers, which I now feel was foolish. It was a 1:1 trade at least, but the Italians were just nicer in general.

I went crazy with different Jet/Choke/Venturi etc settings. I got good advice from this board and things improved a bit. One mystery was the extremely lean main jets that the car had originally. 125's! The engine was set up with a 107 style high rev high power at the top end, or at least this was the best guess as I never got the originally cam specs.

Had an engine fire. Was swapping jets and didn't tighten down the fuel line to the carb well enough and it sprayed a little and whoosh! Fairly minor as I had an extinguisher on hand and got it out in a few seconds, didn't even really burn anything. Replaced the distributor cap and spent 20 hours cleaning out all the Halon dust from the engine compartment. Live and learn.

Work was crazy and I had so many other restoration projects I started to drive her less and less. I had put 20k miles in 3 years and then all of a sudden it was sitting, garaged and covered. It had some really bad days starting and running and I was confused as to the cause, and so many other restoration projects- A 69 BMW R60/2, a 67 BSA Lightning, lots of Porsche's and a ton of friend's projects, etc. A Harley chopper, etc. You know the usual excuses!

I remember fitting some Lotus cam covers off an Esprit I picked up at a swap meet. Looked amazing! This period off the road gradually developed into 12 years!



Back To Top PM Quote Reply

 Posted: 02-11-2020 05:55 am
  PM Quote Reply
5th Post
discogodfather
Member


Joined: 09-17-2007
Location: San Francisco, California USA
Posts: 155
Status: 
Offline
PART V: The Resurrection

Part of the reason this thing sat for so long was the wheels and tires. Started to think- oh, maybe something in my inset/backspace and width was available again, and started checking around from time to time to see on the internet. I became obsessed with trying to re-create the original wheels, one of which had been destroyed. scowered ebay periodically to try and find some western "turbine" wheels but could never find something that would work.

In early January I started the search again and was delighted to find tons of fairly wide rims available for the original Mini Coopers in 13" diameters. Started to notice they were also available in a deep inset (think negative numbers) that I needed. Maybe I just didn't notice earlier but this turned into a fad with original Mini's? Whatever the reason it started to look real good. Found this "new?" outfit called JBW (John Brown Wheels) in the UK that has some awesome designs. Started to wonder which would look good and make sense.

It sealed the deal when I found some matching tires. BF has a Radial T/A in P205/60R13. No luck with the Cooper Cobras, as they didn't have anything in 13". Despite a higher profile this comes to a smaller overall diameter and it's a great fit for these wells, and I am finally getting back to a really light weight setup- 12 lbs for the rim and 18 for the tire!

The rims I went with are the Revolite's from JBW. They are light and in the right inset of -7mm, which is workable for me. They also were very popular for Lotus's at the time as I understand, being on many Europa's and Elan's, etc. Oh, and of course they were on the Lotus 49's and 72's in some configs. The original company that made them is Revolution, which is still around and has some wheels at around twice the price of the JBW copies. Was considering them but they didn't seem to have the right inset. Ended up purchasing the wheels from Mini-Sport USA for a really good price. Shipping was only 2 weeks from the UK. Going to try and do some gold accents on them just like the Forumla 1 wheels. I figure Colin would have picked these at the time if he built a car for Jensen.

On a period Europa:



And the Formula 1 cars. Not sure if these were actual Revolution wheels but they sure have that look/design:








The John Brown Revolites:

Back To Top PM Quote Reply  

 Posted: 02-11-2020 06:01 am
  PM Quote Reply
6th Post
discogodfather
Member


Joined: 09-17-2007
Location: San Francisco, California USA
Posts: 155
Status: 
Offline
Some other new additions:

Aluminum radiator:




Carbs rebuilt:



Lovely Lotus Cam Covers:



Lecarra wheel Jensified:



Engine coming together:

Back To Top PM Quote Reply

 Posted: 02-18-2020 09:25 am
  PM Quote Reply
7th Post
discogodfather
Member


Joined: 09-17-2007
Location: San Francisco, California USA
Posts: 155
Status: 
Offline
Day of truth came after a huge amount of work getting the new 43D Lucas distributor I got fitted with the proper oil seal and draining all the fluids, going through the carbs, and fitting a new battery, etc. Also replaced the fuel pump (it was running a Carter) with a Holley Red.

Well, the Holley red was DOA. It didn't even turn on, after tearing it out and bench testing it was pretty much a paper weight. Not sure what it was but I bought it off Amazon and returned it. Heard many bad things about these pumps so I just cut and run.

There was nothing wrong with the old Carter, but I suspected some pressure drops at higher RPM's so I just wanted to eliminate that as an issue with a higher flow pump. Ended up putting the Carter back in just to see if I could get her started.

She started right away, had the choke on fully. Idled rough until I got the timing set, all good at 0 degrees advance, right?

So then I feel like I time warped back to 2008 and experienced the same issues I had right before she went dormant: as long as the choke was on she ran ok but the idle steadily increased out to 3k or so, always rising. As I took the choke off she died, almost immediately. I could do a basic balance (I have two of those vacuum gauges) and see she was in the ballpark.

This is my initial settings:

Air correctors in all the way
Idle mixture at 1 1/4 turns out

My carb setting are:

Emulsion – F4
Main - 150
Air - 170
Idle - 55F8
Choke - 38
Venturi - 4.5
Pump Jet - 55
Pump Exhaust- 40

The Weber DCOE's are sneezing quite a bit, seeming to suggest it's running lean. Not sure where my float level's are, didn't check that yet. Not sure where to go from here, as the settings seem inline with what they should be. As I adjust the choke, I feel like I am tuning the A/F ratio or something, a weird feeling. What am I getting wrong here?

Some other settings:

Fuel at a steady 3.5 psi
All new ignition including the coil (it's a 3 ohm to run with the electronic ignition in the new 43D)
Great voltage everywhere (new battery)

Last edited on 02-18-2020 09:27 am by discogodfather

Back To Top PM Quote Reply  

 Posted: 02-19-2020 04:19 am
  PM Quote Reply
8th Post
Tom Bradley
Member
 

Joined: 07-15-2013
Location:  
Posts: 185
Status: 
Offline
discogodfather wrote:
She started right away, had the choke on fully. Idled rough until I got the timing set, all good at 0 degrees advance, right?

If you mean that the ignition is firing at TDC when idling, then that is too retarded. The JH shop manual lists static timing varying from 2 deg to 12 deg BTDC. My experience is that the ignition needs to be at least 5 deg BTDC when idling (800-1000 RPM) to get good behavior. Exactly how much depends on how modified from stock everything is. My current (mostly stock) engine likes over 12 deg BTDC best. My previous 2.2L with higher-compression pistons was best at 8 BTDC.

Otherwise, it also sounds to me like the carbs are set too lean. I have zero knowledge of Webers, but I have seen posts listing settings from people who say they are getting good performance. You might try doing a search on "Weber" here and on the Jensen-Healey group on Facebook. You could also ask for help on the Facebook page: there seems to be more people reading that regularly.

Attachment: static timing.jpg (Downloaded 211 times)

Back To Top PM Quote Reply

 Posted: 02-19-2020 05:13 am
  PM Quote Reply
9th Post
Tom Bradley
Member
 

Joined: 07-15-2013
Location:  
Posts: 185
Status: 
Offline
Additional thought: The choke on most carbs is dual-action. It increases the idle speed as well as the mixture. One possibility is that the idle screws need to be turned in to increase the idle speed when the choke is off. My experience is that the idle speed needs to be at least 500RPM to stay running at all. With your engine mods (especially the cams), it may have to be higher than that.

Back To Top PM Quote Reply  

 Posted: 02-21-2020 02:18 am
  PM Quote Reply
10th Post
discogodfather
Member


Joined: 09-17-2007
Location: San Francisco, California USA
Posts: 155
Status: 
Offline
Tom Bradley wrote:
Additional thought: The choke on most carbs is dual-action. It increases the idle speed as well as the mixture. One possibility is that the idle screws need to be turned in to increase the idle speed when the choke is off. My experience is that the idle speed needs to be at least 500RPM to stay running at all. With your engine mods (especially the cams), it may have to be higher than that.

Thanks Tom,

I fiddled with it forever and didn't get anywhere until I came across a forum talking about DCOE's that said the newer Spanish Webers needed the idle mixture screws to be backed out further than the older Italians. The usual is around 1.5 turns from fully in to start, they recommended 4-5 turne out. With the 55F8 idle jets I was able to get her going and pretty smooth and without the choke. Easy enough to time the engine now and it's running at 1000 rpm nicely with around 10 degrees of advance.

The copy Lucas 43D is in there and running good. It has what Powerspark claims is a "high energy" electronic unit that looks pretty robust (it's all rubber coated and looks far less prototype like than a petronix) and it runs great with a low resistance (.7 ohm coil) and apparently runs "dry" and is an epoxy filled unit instead of oil. Used the Chicago Rawhide 4912 oil seal and it's not leaking a drop so far. No idea where the advance curve is, I have to measure it.

A video of it running on my youtube:https://www.youtube.com/watch?v=EOqvUjW2CPE

Now it's time to fiddle more with some progression on the carbs and figure out where she's running at, but great progress!

Last edited on 02-21-2020 02:19 am by discogodfather

Back To Top PM Quote Reply

 Posted: 02-22-2020 10:43 pm
  PM Quote Reply
11th Post
Tom Bradley
Member
 

Joined: 07-15-2013
Location:  
Posts: 185
Status: 
Offline
Congrats on getting it figured out. Looks and sounds awesome! When you get it out on the road, be sure to listen for any knocking. Detonation is especially bad for these engines, so with your higher compression it may be necessary to back off on the timing advance to make sure it does not happen under any circumstances. Have fun!

Back To Top PM Quote Reply  

 Posted: 02-25-2020 03:09 pm
  PM Quote Reply
12th Post
noomg
Member
 

Joined: 08-02-2018
Location: Long Beach, California USA
Posts: 274
Status: 
Offline
When you say you're going to do a "Gold Leaf" car are you going to paint a gold beltline stripe and white underneath? I think that color combo would look awesome on the J-H. When I painted mine I did a bit of a tribute to the JPS cars with a black overall and a double gold body stripe.

Back To Top PM Quote Reply

 Posted: 02-28-2020 06:44 am
  PM Quote Reply
13th Post
discogodfather
Member


Joined: 09-17-2007
Location: San Francisco, California USA
Posts: 155
Status: 
Offline
noomg wrote:
When you say you're going to do a "Gold Leaf" car are you going to paint a gold beltline stripe and white underneath? I think that color combo would look awesome on the J-H. When I painted mine I did a bit of a tribute to the JPS cars with a black overall and a double gold body stripe.

I experimented with the idea of the gold paint on the sideskirts but it's really difficult to pass off on a JH. Also the nose of the grand prix/F1 cars were always painted gold, so I decided to leave it the way the builder originally intended: black sideskirts with a tasteful set of double gold pinstripes between the black and red.

I'm going to try and make it to the Dixon show this year coming up in May put on by the The United British Sports Car Club - UBSCC.

Got the front wheels on tonight, they look great. I got about 3mm of space between the large aluminum JHPS four piston calipers, so it's perfect.

Still messing with the tune. I put the 55F9's idle jets back in and also put the old 125 main's it had in there originally, not 100% sure how the hell this thing runs with 125 main jets but it seems to be better than the 150's!



Back To Top PM Quote Reply  

 Posted: 02-28-2020 03:11 pm
  PM Quote Reply
14th Post
noomg
Member
 

Joined: 08-02-2018
Location: Long Beach, California USA
Posts: 274
Status: 
Offline
Before you make your final decision on paint Google "Lotus Europa gold leaf". While the F1 cars did have a gold nose which I agree is not really practical for road car the Europa had only a gold beltline stripe separating the upper red from the lower white which I think would work well on your J-H and be a real eye catcher.

Back To Top PM Quote Reply

 Posted: 02-29-2020 07:12 pm
  PM Quote Reply
15th Post
discogodfather
Member


Joined: 09-17-2007
Location: San Francisco, California USA
Posts: 155
Status: 
Offline
Finally got the new wheels on, looks great. Much better than the dune buggy look. The old stamped steel 15" wheels with the 255 cobras weighed 43lbs a piece together. The new 205 BFgoodrichs and the 13" weigh 31lbs a piece, so a huge weight savings.

Stripped two wheel studs in the front so decided to replace all of them because they are damn old.

Now she won't start again after I fooled with jets so I am fuddling around trying to see what's up. Thought it might be a timing issue but don't know, I did pop the distributor out because the clamp was too loose. After I but it back in it didn't run. Verified good voltage and a strong spark....hmmmmmm. Timing appears to be in the ballpark.

Anyone know of a method of determining if cylinder #1 is TDC at intake instead of exhaust?

The Lucas 43D is dry as can be, the oil seal I installed works perfectly. The old distributor leaked a bit and I found out it was a badly worn seal, so this is very encouraging. It just leaked a little but anything is bad.





Last edited on 02-29-2020 07:14 pm by discogodfather

Back To Top PM Quote Reply  

 Posted: 03-17-2020 05:46 am
  PM Quote Reply
16th Post
discogodfather
Member


Joined: 09-17-2007
Location: San Francisco, California USA
Posts: 155
Status: 
Offline
In between the world ending I had a really weird experience. I ran her in the morning last week and she had trouble starting, so I wailed away and BOOM. Loudest backfire I have ever heard, the neighbors were all really alarmed. Sounded like a cannon. I thought no big deal, but suddenly power was down and the sound of the exhaust note was pretty muted.

I thought I had seen a good deal in 25 years of working on cars, but this one was new. Always thought backfires could blow up mufflers, seen a few opened like tin cans at a shooting range, but this backfire actually imploded the muffler! Crunched it like someone smacked it with a sledge hammer.



Got it out to a local muffle shop and selected a Flowmaster Super 44. Since my entire exhaust is custom made 2.5" system, there is no spare tire and the muffler just sits there. Sounds great now and a bit of performance is back.





Tried to turn on the old Alpine stereo (probably from the early 80's) and it was dead. Looked around a bit and found a nice unit: a Retrosound. It has bluetooth and is a tiny thing, very well made and it's more retro looking than the Alpine was. It sounds great too with my small 150 watt amp and some custom speakers.








For some reason my theme song with this car is "The Kinks, Living on a Thin Line". Drove it down the pacific coast highway today listening to it.

Also upgraded the starter to a WOSP high torque unit from Britain. Spoke directly with Luke at WOSP and he talked me through some tech issues. This is a Denso unit that is really 3x the starting torque and it's quiet and very modern, drawing less than half the amperage of the stock unit. It's half the size and a third of the weight too. Remarkable little upgrade, my old starter was getting hung up here and there on compression stroke. This one chugs it like it was spinning a dime.

WOSP told me that I didn't need the coil cold enriching circuit, so I left it unhooked. Works just fine. The line running from your coil to the starter basically sends the ignition and extra umpf for starting cold, but because the Denso is so efficient it simply doesn't need it anymore. $350 it's pricey but it works very well and I think it's the best upgrade I have done in this resurrection so far. It's air weight compared to the original, less than 5 pounds. It also allows you to clock it anywhere you like with a custom bolt mounting system. Great immediate customer service from WOSP in the UK.








Back To Top PM Quote Reply

 Posted: 03-30-2020 08:41 am
  PM Quote Reply
17th Post
discogodfather
Member


Joined: 09-17-2007
Location: San Francisco, California USA
Posts: 155
Status: 
Offline
Spent the last few weeks working on her, tons of time since all my clients cancelled on me for the foreseeable future and we're in a "shelter in place" area. Hopefully working on a Jensen Healey is still considered "essential".

Had a problem with her snapping out of 2nd gear (sometimes 4th too) that got progressively worse over the years and decided to look at the transmission mount. It was a soggy mess, came apart in my hand has soon as I got it out. Went ahead and replaced all the mounts, including the motor mounts, which seemed solid but I wanted to make sure. They seemed more on the hard side so it was a good idea too.

Got a shift linkage rebuilt kit from Delta and finally watched the episode of "Wheeler Dealers" on the motortrend channel where they do a 74. Actually a great how to rebuild your shift linkage tutorial, the guy really explained it well and it was a breeze.

Rebuilt the driveshaft and repacked it with grease and painted it. Lubed all the suspension zerks.

My front wheel studs kept failing so I got some from Greg (thanks for the fast shipping) and also had a funny purchase I made a few months ago- a set of EBC "sport" rotors. I bought these basically looking at a picture, thinking they would be thicker. They advertised as slotted and drilled. I was less than impressed when they came. I found a pretty good deal and they were only about $50 more than regular rotors.

But they aren't even worth the extra $50. The rotor is the exact same as stock dimensions, and it has basically a couple of "engraved" slots and little dimples. Really silly. They also powder coat it black, then warn you in the package that you should nor take it off, calling it some kind of heat treatment coating. Then they say it will wear off within the first 10-20 stops. What a joke.

Silliness aside, I really think these are a total waste of time and money. This is probably the last time they will even look cool:





Last edited on 03-30-2020 08:43 am by discogodfather

Back To Top PM Quote Reply  

 Posted: 04-19-2020 11:52 am
  PM Quote Reply
18th Post
discogodfather
Member


Joined: 09-17-2007
Location: San Francisco, California USA
Posts: 155
Status: 
Offline
Decided to pull the head in early April because Covid has me at home out of work. I always wanted to get a better idea of the head, some of the work done to it, and especially the cam ID.

Turns out, after calling Barry Spencer, that it has a Dave Bean Cam called a DB3. It has 420 lift, 290 duration, and 104 MOP. Somewhat hotter than a actual Lotus 104 grind.

I called Dave Bean and they couldn't give me the opening and closing degrees, which was a little odd. They did seem to suggest I could use a 104's timing info from Lotus. Tim Engel generously provided much of the information on that.

The head looks great, dead flat, head gasket was ok (I came to the conclusion there was water in the oil reading the dipstick, but it turned out to be just a little water in the actual dipstick tube.

The head seems to have had some nice porting work, nothing crazy but well done. Valve guides seem fine but I do have to measure a bit more. It's .018" clearance right, both intake and exhaust?

Valve seats look ok but worn, looks like a 3 angle valve job that has a deep throat on both ends. Valves themselves look good, one intake had a little roughness. Plan is to lap and then vacuum check it. If it passes I will put it together, if it fails I will have to cut some new seats. A friend has some Newall stuff and I think I can borrow it.

Question: I usually always skim the deck just to have a nice surface, even if it's just a .001" cut. I noticed how close my valve seats are the edge of the deck, almost zero clearance.

I think this head was decked very close to the chamber in order to get some of the compression lost back when using the thicker newer head gaskets. Does anyone think decking this thing one more time might get into the valve seats? Is that bad for the head gasket? I feel like just a .001-..002" cut would probably have the edge of the seat at the deck height.






Last edited on 04-19-2020 11:53 am by discogodfather

Back To Top PM Quote Reply

 Posted: 04-19-2020 03:28 pm
  PM Quote Reply
19th Post
redracer
Member
 

Joined: 09-10-2012
Location: BROOKHAVEN, Georgia USA
Posts: 394
Status: 
Online
Enjoyed reading all your trials & tribulations with this "never-ending-project"!
One thing you may wish to change is "V" notching the tab on each of the front brakes where your steel flex line goes into the hard lines. This will make it easier to change hubs, bearings, etc., instead of having to rebleed your brake system each time.
Also, I still have a few of the OEM (steel-asbestos-steel) head gaskets if you're interested.
keep us posted, bruce

Back To Top PM Quote Reply  

 Posted: 04-21-2020 06:13 pm
  PM Quote Reply
20th Post
Esprit2
Member
 

Joined: 05-01-2005
Location: Minneapolis, Minnesota USA
Posts: 512
Status: 
Offline
discogodfather wrote:
Valve guides seem fine but I do have to measure a bit more. It's .018" clearance right, both intake and exhaust?You're missing a zero in that clearance dimension... it should be 0.0003"-0.0018" (0.008-0.046 mm), both intake & exhaust.

The stem diameter spec is 0.2805"-0.2810" (7.125-7.137 mm), both intake & exhaust.

Do you have a copy of Tech Data Section A (TDA) from the 1983-87 Lotus Esprit manual? IMHO, all 907 owners should have a copy.

discogodfather wrote:
Question: I usually always skim the deck just to have a nice surface, even if it's just a .001" cut. I noticed how close my valve seats are the edge of the deck, almost zero clearance.

(Snip)... Does anyone think decking this thing one more time might get into the valve seats?
I prefer to never cut the head unless you need to in order to flatten a warp. Even then, first straighten/ flatten the head as much as possible, and then take only the lightest cut possible, as necessary to flatten the bottom.

Taking the maximum cut for any other purpose (ie, compensating for head gasket thickness) just takes away all future options for dealing with a slightly warped head.

But done is done, and it looks to me like all your 'cut options' were previously used up. Times like this are why I resist ever taking a cut that is not required at the time, or taking a deeper cut than is necessary at any time. Always leave as much thickness available for future use as you can.

I understand wanting to scuff the surface to give it a little tooth (maybe a swipe with a Scotchbrite pad), but I wouldn't acutally "cut" any further.

Regards,
Tim Engel

Last edited on 04-22-2020 02:46 pm by Esprit2

Back To Top PM Quote Reply

Current time is 02:09 pm Page:    1  2  3  Next Page Last Page    
> Jensen Healey & Jensen GT Tech > Projects > 1973 Jensen Healey #10777 Lotus "Colin Chapman" Edition "Gold Leaf" Build Top




UltraBB 1.172 Copyright © 2007-2011 Data 1 Systems