Home 
Home Search search Menu menu Not logged in - Login | Register

 Moderated by: Greg Fletcher Page:  First Page Previous Page  1  2  3   
New Topic Reply Printer Friendly
Front suspension  Rating:  Rating
AuthorPost
 Posted: 01-17-2015 07:58 pm
  PM Quote Reply
41st Post
Screenplay
Member
 

Joined: 07-12-2013
Location: San Francisco, California USA
Posts: 124
Status: 
Offline
Hi Eric,

Flat side UP against the rubber seat that sits against the subframe. The lower control arm is shaped to accept the bottom of the spring and will fit only one way. Upon reassembly, before the bottom side of the spring and the lower arm make contact, rotate the spring until it fits "snugly" in that lower control arm. You'll see the contour and how it fits.

It sounds as if you're making some real progress. If only I could get mine to move as quickly! Best of luck.

Clinton

Last edited on 01-17-2015 09:36 pm by Screenplay

Back To Top PM Quote Reply  

 Posted: 01-17-2015 11:58 pm
  PM Quote Reply
42nd Post
Eric
Member
 

Joined: 11-11-2014
Location:  
Posts: 35
Status: 
Offline
Okay thanks! It seems like it makes more sense to mount the spring in the lower control arm first, though.

Back To Top PM Quote Reply

 Posted: 01-18-2015 12:35 am
  PM Quote Reply
43rd Post
Screenplay
Member
 

Joined: 07-12-2013
Location: San Francisco, California USA
Posts: 124
Status: 
Offline
Eric,

Yes, that does make good sense, especially if you're using a floor jack to push it all together. I always use an internal spring compressor and it moves around a lot while I'm loosening the bolt and I end up having to rotate it back into place.

Clinton

Back To Top PM Quote Reply  

 Posted: 01-18-2015 12:43 am
  PM Quote Reply
44th Post
Eric
Member
 

Joined: 11-11-2014
Location:  
Posts: 35
Status: 
Offline
Yes..I'm using the floor jack. I have to wonder how the people who mounted the spring flat side down got it to engage in the lower arm.

Back To Top PM Quote Reply

 Posted: 01-24-2015 01:51 am
  PM Quote Reply
45th Post
Eric
Member
 

Joined: 11-11-2014
Location:  
Posts: 35
Status: 
Offline
Just wanted to say "thank you" for all the helpful advice above. Cannot imagine doing this without the tips of others. Got new front springs, shocks, tie rod ball joints and steering boots replaced. As was mentioned above, using two floor jacks when reassembling helps line up the shock bracket, castor rod and lower control arm so you can drop in those two bolts. For what it's worth, I kept the solitary inboard shock mounting bolt attached to the shock mounting plate, although loosened. The shock was still able to fall out between the two halves of the mounting bracket. Doing this seemed to make aligning the two outboard mounting bolts fairly easy on assembly.

Back To Top PM Quote Reply  

 Posted: 11-01-2016 08:52 pm
  PM Quote Reply
46th Post
little red
Member
 

Joined: 04-18-2016
Location: Fort Myers, Florida USA
Posts: 20
Status: 
Offline
Finally three days and the front springs and shocks are installed. The PO rounded most of the nuts on the front end. Between a file, vice grips, hammer and chisel a little heat and plenty of blaster I managed to get it all apart. little red is riding a little higher and much smother due to the Bilstein shocks. The rear springs and shocks were a cake walk compared to the front. But all is well that ends well. Thanks again to Greg for having the Bilsteins available.

Back To Top PM Quote Reply

 Posted: 09-07-2023 01:57 am
  PM Quote Reply
47th Post
dbeliveau74
Member


Joined: 12-28-2015
Location: Manchester, New Hampshire USA
Posts: 53
Status: 
Offline
I have read this thread several times trying to get everything of info. I have everything apart except the crossmember. Bra ed the engine removed the motor mount nuts, loosened the pinch bolt on the lower u joint of the steering arm, removed nuts from the frame mount bolts for the crossmember bushings, lower fulcrum bolts are loose and moved forward. I am still unable to lower the crossmember am I missing something? Any advice would be greatly appreciated. Cheers, Dan.

Back To Top PM Quote Reply  

 Posted: 09-08-2023 01:15 am
  PM Quote Reply
48th Post
dbeliveau74
Member


Joined: 12-28-2015
Location: Manchester, New Hampshire USA
Posts: 53
Status: 
Offline
Anyone have any insight?
Everything is down but the crossmember. Got the steering rack D bolts out, steering rack down, lower arms down, but the crossmember still seems attached to the lower frame?? Is there another attaching bolt i missed?
All my workshop manuals and parts catalog have the same diagram. Unless the PO welded the crossmember to the frame I can't imagine what is holding it together.
Any suggestions would be greatly appreciated.
Thanks,
Cheers,
Dan

Back To Top PM Quote Reply

 Posted: 09-10-2023 06:27 pm
  PM Quote Reply
49th Post
Tom Bradley
Member
 

Joined: 07-15-2013
Location:  
Posts: 203
Status: 
Offline
Did you also remove the mounting to crossmember bolts (#4 on the pic)? if so, then it is likely, that the crossmember is just being held on by pressure between the crossmember and the mounting assembly. Try spraying this area with WD-40, or some such and using a rubber mallet to tap the crossmeber down.

Attachment: Front suspension detail.jpg (Downloaded 45 times)

Back To Top PM Quote Reply  

 Posted: 09-10-2023 07:59 pm
  PM Quote Reply
50th Post
dbeliveau74
Member


Joined: 12-28-2015
Location: Manchester, New Hampshire USA
Posts: 53
Status: 
Offline
Yes I did remove the bolt #4.
It seems to be firmly attached to the lower frame.
Even after removing the steering rack.

Attachment: Frt Susp Torques.gif (Downloaded 43 times)

Back To Top PM Quote Reply

 Posted: 09-10-2023 08:08 pm
  PM Quote Reply
51st Post
dbeliveau74
Member


Joined: 12-28-2015
Location: Manchester, New Hampshire USA
Posts: 53
Status: 
Offline
Son of a gun!!
I just noticed something as I was looking at my parts catalog!
The rear crossmember mounting bolt.
It appears that is the culprit!;)

Back To Top PM Quote Reply  

 Posted: 09-10-2023 08:15 pm
  PM Quote Reply
52nd Post
dbeliveau74
Member


Joined: 12-28-2015
Location: Manchester, New Hampshire USA
Posts: 53
Status: 
Offline
So now my question is does #3 mounting assembly need to be replaced? And is it available?
I'll check the club store, etc.
After this I think I'll write up a tech article about this job in a little more detail than I found.
Cheers!
Dan

Attachment: Screenshot_20230910-163849_Chrome.jpg (Downloaded 44 times)

Last edited on 09-10-2023 09:54 pm by dbeliveau74

Back To Top PM Quote Reply

 Posted: 09-11-2023 02:08 am
  PM Quote Reply
53rd Post
Tom Bradley
Member
 

Joined: 07-15-2013
Location:  
Posts: 203
Status: 
Offline
Not sure if the mounting assembly needs to be replaced. What sort of condition is it in? It looks like it may have some rubber cushioning which could go bad. Depends on how thorough and conservative a job you want to do. Martin Robey has them in stock. Delta motorsports may as well.

Back To Top PM Quote Reply  

 Posted: 09-11-2023 07:15 pm
  PM Quote Reply
54th Post
redracer
Member
 

Joined: 09-10-2012
Location: BROOKHAVEN, Georgia USA
Posts: 634
Status: 
Offline
Dan: just saw this new thread; glad to see you found the "missing" link and have it down. I would strongly suggest you add a 1/8" or more washer/plate to the front of the subframe for the lower arm bolt..
Here's a link from a previous post I did on this:
http://www.jensenhealey.com/forums/view_topic.php?id=2717&forum_id=8&highlight=lower+arm

Please call/email/ or SKYPE me if you need further help. All my info is in my profile.
bruce/redracer

Back To Top PM Quote Reply

Current time is 08:12 pm Page:  First Page Previous Page  1  2  3     
> Jensen Healey & Jensen GT Tech > Suspension > Front suspension Top




UltraBB 1.172 Copyright © 2007-2011 Data 1 Systems