Home 
Home Search search Menu menu Not logged in - Login | Register
> j4jacob

Profile Topics Posts
Posts by j4jacob
11 postsShowing posts 1-11 of 11

Engine & Transmission > Distributor Oil Leak 76 GT (0 replies - 1829 views)

I've replaced the oil seal o-ring on the distributor shaft and it still leaks.  Both breather tubes that vent to the cold air box are unobstructed so I don't ...   02-09-2008 04:12 pm

Fuel Stuff > Gas Tank Cap MIA (0 replies - 3448 views)

I managed to leave my Jensen GT gas cap at the pump and it is apparently gone for good.  Delta didn't have one and provided a ...   01-30-2008 07:47 pm

Engine & Transmission > Clutch Cable Installation--Help! (3 replies - 4498 views)

    Thanks Steve!  Once you put me on the right course, it wasn't a bad job, just a bit fiddly and time consuming. Most appreciated....Albert ...   10-31-2007 01:23 am

Engine & Transmission > Clutch Cable Installation--Help! (3 replies - 4498 views)

For some reason, the shop manual I have doesn't cover clutch cable installation very well.  Since the old one had snapped I had no trouble removing ...   10-27-2007 08:08 pm

Ignition > Spark for Number 2 is MIA (9 replies - 6711 views)

Postmordem:  It turned out to be a failed Pertronix Module.  I'm not sure why it failed but it was about a year old and had very few ...   10-05-2007 01:57 am

Ignition > Spark for Number 2 is MIA (9 replies - 6711 views)

     Good thought John.  Unfortunately I was not the one who installed the Pertronix and none of the old stuff came with the car.  Points/condensers ...   09-29-2007 06:04 am

Ignition > Spark for Number 2 is MIA (9 replies - 6711 views)

As Judson suggested I pulled the distributor whereupon I discovered signs of SLIGHT interference between the rotor and the top of the Pertronix module.   The module had some light ...   09-28-2007 10:47 pm

Ignition > Spark for Number 2 is MIA (9 replies - 6711 views)

Greetings all.  I'm blasting down the highway this evening accelerating hard (but nowhere close to redline, about 5K) and the engine looses power abruptly.  I ...   09-26-2007 04:20 am

Engine & Transmission > Cam Belt--To Cover or Not to Cover (3 replies - 3132 views)

    Cambelt cover(s) on my 1976 GT seem to be rubbing the belt ever so slightly.  (I THINK I can hear it scuffing from time ...   09-25-2007 02:03 am

Electrical & Instruments > Fuel Pump Inertia Switch (3 replies - 3833 views)

    Thanks Greg and Judson.  The inertia switch was actually not hard to find once I took the time to really look around.  At least ...   08-11-2007 06:39 pm

Electrical & Instruments > Fuel Pump Inertia Switch (3 replies - 3833 views)

Power to my fuel pump is cutting in and out.   Anyone know where the inertia switch is in a Jensen GT? Thanks in advance,  Albert   ...   08-04-2007 09:34 pm


 Current time is 08:15 pm
 


UltraBB 1.172 Copyright © 2007-2011 Data 1 Systems