Home 
Home Search search Menu menu Not logged in - Login | Register
> Jensen Healey & Jensen GT Tech > Ignition > Pertronix failure

 Moderated by: Greg Fletcher
New Topic Reply Printer Friendly
Pertronix failure  Rate Topic 
AuthorPost
 Posted: 11-02-2015 05:14 pm
  PM Quote Reply
1st Post
Frank Schwartz
Member
 

Joined: 02-18-2011
Location:  
Posts: 246
Status: 
Offline
Working on a friends JH and we replace the coil with a Blaster (MSD) coil and the recommended resistor and used a Pertronix unit in the distributor. All went well until the car just went dead after only 50 miles. Replaced the coil and checked the resistor. Still absolutely no spark. Took the Pertronix unit back to the retailer who graciously gave me another and said that they rarely failed. I also, never had one fail, however, this one seemed to fit closer inside the distributor to the rotating magnet unit. Nonetheless, when I installed the unit and turned the key, the car started instantly and I found that it now had a ferocious spark. Therefore, I found the original Pertronix unit I purchased was defective and a replacement unit solved the problem....
I wonder if anyone ever had a Pertronix unit fail.

Finally, I now have a problem wioth idling which is varying and not good. I suspect an air leak somewhere.

Back To Top PM Quote Reply  

 Posted: 11-03-2015 01:05 pm
  PM Quote Reply
2nd Post
subwoofer
Member
 

Joined: 04-01-2008
Location: Sandefjord, Norway
Posts: 583
Status: 
Offline
I think the old Ignitors had a habit of going up in smoke if the ignition was left on for any amount of time without the engine running, but I think that was fixed. The Ignitor II is supposed to be immune, at least.

--
Joachim

Back To Top PM Quote Reply

Current time is 06:36 pm  
> Jensen Healey & Jensen GT Tech > Ignition > Pertronix failure Top




UltraBB 1.172 Copyright © 2007-2011 Data 1 Systems