Home 
Home Search search Menu menu Not logged in - Login | Register

 Moderated by: Greg Fletcher
New Topic Reply Printer Friendly
Engine dies  Rating:  Rating
AuthorPost
 Posted: 11-15-2007 06:22 pm
  PM Quote Reply
1st Post
tjmurphey
Member
 

Joined: 05-24-2005
Location:  
Posts: 5
Status: 
Offline
I think this is an electrical issue.  The problem is that my 73 JH just stops running.  This has happened twice.  The engine simply stops running and the tachometer pins itself.  If i turn the ignition off and then engage the starter it fires right up again.  This last happened while I was in the fast lane of a busy highway.  Kind of surprised me and probably the guy who was tailgating me too.  This is probably unrelated but I was informed when I got to town that my brake lights weren't working. 

So, any ideas as to the cause?  Thanks

Back To Top PM Quote Reply  

 Posted: 11-16-2007 01:23 pm
  PM Quote Reply
2nd Post
Brett Gibson JH5 20497
Member
 

Joined: 03-17-2005
Location: Hilton, New York USA
Posts: 786
Status: 
Offline
Well the most common tail light failure is bad grounds, try a jumper ground and see what happens, as for engine, could be a ton of things, but seeing grounds are a suspect at the rear, check your wiring connections along your ignition wires, quickest way to lean those connections is to dip them in a acid solution then rinse in water, they come out looking brand new.

Good luck,     Brett.

Back To Top PM Quote Reply

 Posted: 11-18-2007 02:50 pm
  PM Quote Reply
3rd Post
tjmurphey
Member
 

Joined: 05-24-2005
Location:  
Posts: 5
Status: 
Offline
At least I think I found the problem with the brake lights.  The switch doesn't seem to work any more.  Anybody know how to remove/replace one? 

Back To Top PM Quote Reply  

Current time is 01:55 am  
> Jensen Healey & Jensen GT Tech > Electrical & Instruments > Engine dies Top




UltraBB 1.172 Copyright © 2007-2011 Data 1 Systems