Home 
Home Search search Menu menu Not logged in - Login | Register
> jarnol123

Profile Topics Posts
Posts by jarnol123
95 postsShowing posts 81-95 of 95

Ignition > No Spark (14 replies - 8902 views)

OK I've got the dizzy out...(see picture). Do I have to take anything else out or does the ignitor just fit on top? The directions ...   10-16-2010 06:44 pm

Ignition > No Spark (14 replies - 8902 views)

I checked and my distributor is a 7755D... Would the Pertronix Ignitor work with this?? Or would it be the Ignitor II and Ignitor III? ...   10-12-2010 05:31 am

Ignition > No Spark (14 replies - 8902 views)

OK i turned the engine and the rotor turned ok...you know when the car was running it fine then it started to misfire a bit ...   10-10-2010 06:54 pm

Ignition > No Spark (14 replies - 8902 views)

if the allison unit is shot would you have a recommendation for a replacement unit? ...   10-10-2010 06:07 pm

Ignition > No Spark (14 replies - 8902 views)

OK I'll check the dizzy next and report back ...   10-10-2010 06:05 pm

Ignition > No Spark (14 replies - 8902 views)

don't want to sound dumb but how do i check the points? I have a allison electronic ignition near the battery...would i still have points ...   10-10-2010 12:20 am

Ignition > No Spark (14 replies - 8902 views)

Yes I ran the 12v from the battery to the coil directly and no spark. I've had the dizzy cap off already and i was ...   10-09-2010 11:04 pm

Ignition > No Spark (14 replies - 8902 views)

Ok here's what i've done so far... Car used to run then one day just spluttered and stopped. Couldn't get it to start again. Since then ...   10-09-2010 08:02 pm

Ignition > Dead electrics and starting problems (14 replies - 9794 views)

Well, I think the electrics are ok now. I think it's a fuel problem, ie when I turn the engine over fuel is getting to ...   03-28-2010 04:07 pm

Ignition > Dead electrics and starting problems (14 replies - 9794 views)

ok i'll give it a go at the weekend and report back. ...   12-08-2009 02:31 am

Ignition > Dead electrics and starting problems (14 replies - 9794 views)

Ok, well i got power back and i can now turn the engine over, (there wasn't a good connection at the positive terminal on the ...   12-07-2009 01:26 pm

Ignition > Dead electrics and starting problems (14 replies - 9794 views)

i replaced the 3 fuses with the correct UK 35A fuses. The battery is fully charged and still nothing. I turn the key and there ...   12-04-2009 05:43 am

Ignition > Dead electrics and starting problems (14 replies - 9794 views)

Ok, now I have nothing at all. I turn on the ignition and there is nothing. I replaced all 3 fuses with authentic 35amp fuses. ...   10-19-2009 04:44 am

Ignition > Dead electrics and starting problems (14 replies - 9794 views)

Thanks for the reply. I'm going to replace the 3 fuses (using english fuses) and check all connections again. Wil let you know what happens. ...   10-04-2009 04:37 am

Ignition > Dead electrics and starting problems (14 replies - 9794 views)

New to the forum. I have a 1975 Jensen Healey that was running then one day as I was driving dow the road it started ...   10-02-2009 05:12 am


 Current time is 11:27 pm
 First Page Previous Page  1  2  3 


UltraBB 1.172 Copyright © 2007-2011 Data 1 Systems