Home 
Home Search search Menu menu Not logged in - Login | Register
> Jensen Healey & Jensen GT Tech > Carburetors > Out of tune Stroms causing sputter/rough running?

 Moderated by: Greg Fletcher
New Topic Reply Printer Friendly
Out of tune Stroms causing sputter/rough running?  Rate Topic 
AuthorPost
 Posted: 05-08-2007 03:53 am
  PM Quote Reply
1st Post
flatlanderep
Member


Joined: 06-24-2006
Location: Charlotte, North Carolina USA
Posts: 61
Status: 
Offline
Does anyone have a writeup (with lots of pictures) for tuning Stroms?
I have the JH manual, but I'm a very visual person, so pictures would definately help me make sense of it all.

After installing the pertronix distributor (refer to extremely long thread in ignition section), the car "sputters" when  light on the throttle.

It was doing this prior to the new distributor, so I suspect its somewhere in the fuel/air mixture.....hence the carbs. Is that what it sounds like to you guys, or should I look in a completely different direction?

Back To Top PM Quote Reply  

 Posted: 05-10-2007 04:58 pm
  PM Quote Reply
2nd Post
Greg Fletcher
Administrator


Joined: 03-11-2005
Location: Lake Nacimiento, California USA
Posts: 421
Status: 
Offline
JHPS member Mark Rosenbaum did a great write up on the Stromberg 175CD's a while back, I need to dig that out. There's also an old Haynes manual out of the UK that only deals with rebuilding Strombergs and I've always found that very helpful too.

Hard to say on your problem, can you give us more detail? Did you check the mixture? Is the fuel system and filter reasonably clean?

Back To Top PM Quote Reply

 Posted: 05-14-2007 03:03 am
  PM Quote Reply
3rd Post
flatlanderep
Member


Joined: 06-24-2006
Location: Charlotte, North Carolina USA
Posts: 61
Status: 
Offline
Greg, the filter is clean and as far as the mixture, I'm not too sure. How do I check that? To me it seems like its running a little rich, sputtering evey now and then when you press the pedal. At full throttle and idle its fine, it just happens upon acceleration.

Timing's right, spark plugs new, wires new, fuel filter good.....etc. all that good stuff.

Quick question at the end of this rambling:

right now the fuel filter is placed directly after the pump, is there supposed to be one before pump as well? (side note > we had one before the pump a few months back, and some lousy mechanic removed it because he said that two was overkill).

Back To Top PM Quote Reply  

 Posted: 05-14-2007 04:20 am
  PM Quote Reply
4th Post
Mark Rosenbaum
Member


Joined: 03-12-2005
Location: Kingman, Arizona USA
Posts: 532
Status: 
Offline
At the absolute minimum, there should be a filter upstream of the fuel pump to protect the pump from rust and debris in the fuel tank.  IMHO there should also be a filter just upstream of the tee between the two carburetors, to protect the carbs from any rust developing in the fuel line itself, or from disintegration of the pump internals.  If this is overkill, so what? -- no harm is done.

Poor response during acceleration is most often caused by low or incorrect damper oil.  Almost invariably, with a stock or nearly stock engine, the correct oil choice is the same viscosity as that used in the crankcase: 20W50 whenever the average temperature is 32°F or above, or 10W40 when colder.

Sections C11 and D3 of the shop manual contain the official procedures for setting up the balance and fuel/air mixture adjustments on Stromberg carburetors, but they were written more as guidelines for the professional mechanic in an era where Strombergs were considerably more common than nowadays.  I've been toying with a rough draft of a carburetor adjustment procedure that may be more convenient for the modern owner.  Send me an email if you'd like a copy to try out.

Back To Top PM Quote Reply

Current time is 12:44 pm  
> Jensen Healey & Jensen GT Tech > Carburetors > Out of tune Stroms causing sputter/rough running? Top




UltraBB 1.172 Copyright © 2007-2011 Data 1 Systems