Home 
Home Search search Menu menu Not logged in - Login | Register
> Jensen Healey & Jensen GT Tech > Ignition > 1973 JH #IIIO IGNITION

 Moderated by: Greg Fletcher
New Topic Reply Printer Friendly
1973 JH #IIIO IGNITION  Rating:  Rating
AuthorPost
 Posted: 07-21-2006 09:17 pm
  PM Quote Reply
1st Post
matthew falconer
Member
 

Joined: 07-21-2006
Location:  
Posts: 1
Status: 
Offline
     Mr. Fletcher, I hope I'm doig this right ,as I just became a member today!

        It's not like I'm not familiar with lucas<aka..THE PRINCE OF DARKNESS >,because, I'v had a mini ooper,austin healey, jag, etc.Also raced triumph and BSA motorcycles for a living back in the 70s,but this has me stumped!

      I installed new points & condenser, I also fond many wires frayed and in bad shape ,and replaced them. Also I found the ballast resistor was bad and,after reading Mark R's post on how to test coil ,found coil was also bad. I replced them with a std. 12 volt coil and a axcel ,<HIGH OUTPUT>, ballast resistor, for lack of lucas parts in my part of Nortern California < Placerville>. Also went though distributor,replaced the breaker plate ground wire and everthing is good. I'v got points set @ 16 ,and with ignition on , dist. out of block everything is cool! As soon as touch it to motor block ,I get a spark and , of course ground ,and ..... I even tryed running a remote ground stap from coil bracket to motor block etc etc . I also thought it might be the dist plastic termanal - ,but after pulling it free frm dist. body everything still grounds out. Any HELP at all would be GREAT!

      I'v read about a few of the members' wifes/girlfriends saying ;:does it run yet ?? etc:".... I bought this JH for my wife at the begaining of summer, ..TO MAKE HER HAPPY, she drove it four days and was happy!Did I mention she is full blooded American Indian?...Custer's last stand would be like a cake walk ,if I don't get her a running soon!

      THANKS  MATTHEW!!!!

Last edited on 07-23-2006 01:01 am by matthew falconer

Back To Top PM Quote Reply  

 Posted: 07-24-2006 02:18 pm
  PM Quote Reply
2nd Post
Brett Gibson JH5 20497
Member
 

Joined: 03-17-2005
Location: Hilton, New York USA
Posts: 713
Status: 
Offline
Matthew, I dont quite follow what your troubles are, but if your getting zapped with the ignition ON, when you touch the engine block ??? then I would think you have a bad engine ground.

Brett. 

Back To Top PM Quote Reply

Current time is 03:17 pm  
> Jensen Healey & Jensen GT Tech > Ignition > 1973 JH #IIIO IGNITION Top




UltraBB 1.172 Copyright © 2007-2011 Data 1 Systems