Home 

 Moderated by: Greg Fletcher  
AuthorPost
Spaceman
Member


Joined: 05-30-2017
Location:  
Posts: 14
Status: 
Offline
Finally got my car to run, oil pressure problems etc, but now I don't see any water running thru the upper hose? Also my temp gauge doesnt' show any movement. When I squeeze the hose before the thermostat, I can hear air move thru, I think the thermostat is stuck open.

So why do I not see water pumping thru the system? I wonder if I have an air bubble, or the impeller is gone?

Any Ideas?

redracer
Member
 

Joined: 09-10-2012
Location:  
Posts: 119
Status: 
Online
If the "upper hose" you are referring to is the one to the radiator, the water should NOT flow through it until the 165 or 180 degree Farenheit is acheived, assuming you have one of the 2 standard thermostats. The 2 stage thermostat will gradually close the hole back to the pump and simultaneously open to the radiator.
As for the "NO" temperature, how long did the engine run? Sometimes it can take 10 minutes(especially in wintertime) to reach the "OPEN" thermostat settings.
I am assuming that all fluid have been set to their proper levels?
bruce

Spaceman
Member


Joined: 05-30-2017
Location:  
Posts: 14
Status: 
Offline
I haven't run it for more than 4 minutes, as I fear overheating, interesting info on the 2 stage thermostat, yes I have been reading the thermostat must be closed for the engine to heat up properly. Once I fix the carb leaky gasket, I will run it for 10 minutes, and test the water temp gauge.

thanks Bruce

redracer
Member
 

Joined: 09-10-2012
Location:  
Posts: 119
Status: 
Online
whoa...leaky carb.? That rear carb sits right over the starter--it's called instant fire(hope you brought the marshmallows).
Please have a fire extinguisher ready if you are unsure of the carbs; can't tell you how many cars have been burned up this way.

Spaceman
Member


Joined: 05-30-2017
Location:  
Posts: 14
Status: 
Offline
I have had 2 on hand for every test, first the oil seal went, then carb #1 overfilled and spewed, and then carb 2 had no fuel. Replaced float valve, now the gasket leaks.

My car was damaged by fire a long time ago, everything was melted. Wire harness has completely melted together. Air box, wiper bottle, rad overflow, gone. And both carbs were melted, and seized. But I was lucky, and found another Jensen Healey owner with a second parts car.

I might mount one under the hood with a quick release inside the cockpit.

cheers
D.

Spaceman
Member


Joined: 05-30-2017
Location:  
Posts: 14
Status: 
Offline
leak appears to be fixed, now to run it up to temp and test the temp gauge. Also need to pull the dash out and change all the bulbs, and replace the oil gauge, it blew up when my oil relief valve jammed, and oil pressure was past 100.



UltraBB 1.172 Copyright © 2007-2011 Data 1 Systems