Home 
Home Search search Menu menu Not logged in - Login | Register
> Jensen Healey & Jensen GT Tech > Ignition > Ignition Issues,engine quits when hot!

 Moderated by: Greg Fletcher
New Topic Reply Printer Friendly
Ignition Issues,engine quits when hot!  Rate Topic 
AuthorPost
 Posted: 10-24-2016 03:33 pm
  PM Quote Reply
1st Post
rovohn
Member


Joined: 07-08-2012
Location: Langley, British Columbia Canada
Posts: 22
Status: 
Offline
I have a 76 GT with points ignition,recently the car has decided to either quit or refuse to start when hot or at running temp and the coil is quite warm.If I let the car cool down for about 15-30 mins it will start again.
Anyone have any ideas,Coil,condenser,ballast?
Cheers,John

Back To Top PM Quote Reply  

 Posted: 10-24-2016 06:14 pm
  PM Quote Reply
2nd Post
redracer
Member
 

Joined: 09-10-2012
Location:  
Posts: 119
Status: 
Offline
Was everything running OK until recently? If you do change the coil, be sure it is a 1.5 ohm one as the GTs have the 1.5 nickel-chromium resistive wire going to it(giving 3 ohm for "RUN" condition).
We usually "shotgunned" the ignition items(points, plugs, wires, rotor, condenser, cap)so we can start from scratch.
We have had BRAND NEW points bad, as there was a little too much clamping down on the riveted fulcrum post, causing the dwell to increase to the point of stopping the engine running.
As for coils, I have rarely seen one go bad on our J-Hs or Healeys, the few exceptions being oil oozing from the top.

Back To Top PM Quote Reply

 Posted: 10-24-2016 06:31 pm
  PM Quote Reply
3rd Post
rovohn
Member


Joined: 07-08-2012
Location: Langley, British Columbia Canada
Posts: 22
Status: 
Offline
Yes it was just recently,it ran great before.
I think I will buy a new 1.5 ohm coil and see what happens.
All of the other components are working ok,that being said I will check the points and replace the condenser
Cheers,John

Back To Top PM Quote Reply  

 Posted: 10-25-2016 07:11 am
  PM Quote Reply
4th Post
subwoofer
Member
 

Joined: 04-01-2008
Location: Sandefjord, Norway
Posts: 583
Status: 
Offline
Did you change the rotor (semi-)recently? If you have a rotor with a metal rivet in it holding the conductor to the rotor plastic, that could be your problem. I chased a misfire-while-hot problem for over two years before someone alerted me of the rotor problem.

--
Joachim

Back To Top PM Quote Reply

 Posted: 11-02-2016 05:32 pm
  PM Quote Reply
5th Post
rovohn
Member


Joined: 07-08-2012
Location: Langley, British Columbia Canada
Posts: 22
Status: 
Offline
I replaced the coil with a 1.5 ohm,had it out for a good run this past Sunday ran great,let's hope it stays that way.

Back To Top PM Quote Reply  

Current time is 06:36 pm  
> Jensen Healey & Jensen GT Tech > Ignition > Ignition Issues,engine quits when hot! Top




UltraBB 1.172 Copyright © 2007-2011 Data 1 Systems