Home 

 Moderated by: Greg Fletcher  
AuthorPost
roland11a
Member
 

Joined: 12-11-2012
Location: Stone. Staffordshire, United Kingdom
Posts: 80
Status: 
Offline
Hi
Just setting up my Dellorto carbs following the re-build. The carbs have been re-built with a full kit including spindle bearings.
My question is? When I start the engine with the choke operating I get a loud sucking noise which sound just like an air leak. I spent ages looking for the leak only to find  the noise goes once the choke is pushed in. Having never heard the JH running I'm not sure what sounds are normal.
Can any one with dellortos fitted advise if they get a similar noise?

gmgiltd
Member
 

Joined: 07-10-2012
Location: Whitehills , United Kingdom
Posts: 142
Status: 
Offline
It's normal - no need for concern.
Gordon

Jensenman
Member
 

Joined: 04-14-2005
Location: Columbia, South Carolina USA
Posts: 156
Status: 
Offline
Yes, it's normal. Dellortos have a high idle provision which is nothing more than a poorly controlled and noisy vacuum leak. Use it as little as possible; whenever you hear that the cold start mechanism is also sucking extra fuel. That means a very rich mixture which not only can foul spark plugs but can 'wash down' cylinder walls with extra fuel. I use mine till the engine starts, leave it out for about 5 seconds, then push it closed and use the throttle pedal to keep the engine running.

Lacy
Member
 

Joined: 11-23-2013
Location:  
Posts: 7
Status: 
Offline
Yep, mine does that.....I don't use it at all. I just give the pedal three pumps before turning over then once the engine catches just feather the throttle for 10 seconds or so then everything is fine.



UltraBB 1.172 Copyright © 2007-2011 Data 1 Systems