Home 
Home Search search Menu menu Not logged in - Login | Register

 Moderated by: Greg Fletcher
New Topic Reply Printer Friendly
ZS Rebuild Time?  Rate Topic 
AuthorPost
 Posted: 01-04-2010 03:35 am
  PM Quote Reply
1st Post
SpeedyMitch
Member


Joined: 12-17-2009
Location: Hailey, Idaho USA
Posts: 83
Status: 
Offline
New to me JH 12827 (73 Mk 1) was running 'just fine' last May according to the PO. For me it starts and idles as normal, but only for several seconds (about 10-30 seconds). When time is up the motor just stops. It seems that if I keep the revs up it will run longer, sometimes.

Suspecting the original SU fuel pump I replaced it with a simple Carter 2-4 PSI unit from Napa and inspected the fuel filter (located in the trunk, after the SU pump, and oriented in the 'wrong' direction). The filter was clean but I replaced it anyway. The new pump does not seem to have made a difference.

Currently, there is no filter between the fuel line and the dreaded, soon-to-be-replaced, plastic 'T' between the carbs.

Next I inspected and removed the carb dash pots. The diaphragm for the forward carb has some small wrinkles that have split while the rear carb's diaphragm looks OK.

I'm guessing it is time to order the ZS rebuild kit? While I'm at it, what other tools, parts, fittings, etc should I order? Does the rebuild kit have decent instructions or is there another manual that would be beneficial?

Thanks in advance for any help, guidance, or advice,

Speedy Mitch

Back To Top PM Quote Reply  

 Posted: 01-04-2010 01:58 pm
  PM Quote Reply
2nd Post
Judson Manning
Member


Joined: 03-14-2005
Location: Atlanta, Georgia USA
Posts: 406
Status: 
Offline
Sounds like a fairly typical issue. Floats may be stuck and/or gross-jets may be clogged w varnish, etc. A full rebuild may not be necessary, but a good soaking in carb cleaner probably is.

Back To Top PM Quote Reply

 Posted: 01-07-2010 06:56 pm
  PM Quote Reply
3rd Post
SpeedyMitch
Member


Joined: 12-17-2009
Location: Hailey, Idaho USA
Posts: 83
Status: 
Offline
SpeedyMitch wrote: New to me JH 12827 (73 Mk 1) was running 'just fine' last May according to the PO. For me it starts and idles as normal, but only for several seconds (about 10-30 seconds). When time is up the motor just stops. It seems that if I keep the revs up it will run longer, sometimes.

I have found the source of this problem. Turns out there is a short or faulty circuit in the ignition switch. If I keep just a bit of pressure on the key after starting the JH runs fine. I squirted a bit of contact cleaner into the lock and that seems to have helped, but not solved, the problem.

How do you remove the cowling around the lock to inspect it? It seems that I would have to take the steering wheel off first???

Thanks in advance,

Speedy Mitch

 

Back To Top PM Quote Reply  

 Posted: 01-08-2010 04:40 am
  PM Quote Reply
4th Post
Jensen Healey
Super Moderator


Joined: 03-11-2005
Location: San Anselmo, California USA
Posts: 976
Status: 
Offline
Hi Mitch,

90% of carburetor problems...

My cowl seems to have been cut to allow easy removal after the steering wheel is off.  I have no idea what the original looks like.

Back To Top PM Quote Reply

Current time is 07:32 am  
> Jensen Healey & Jensen GT Tech > Carburetors > ZS Rebuild Time? Top




UltraBB 1.172 Copyright © 2007-2011 Data 1 Systems