Home 
Home Search search Menu menu Not logged in - Login | Register
> Jensen Healey & Jensen GT Tech > Brakes > Brake light on after hose replacement

 Moderated by: Greg Fletcher Page:  First Page Previous Page  1  2   
New Topic Reply Printer Friendly
Brake light on after hose replacement  Rating:  Rating
AuthorPost
 Posted: 06-02-2008 09:35 pm
  PM Quote Reply
21st Post
edward_davis
Member


Joined: 07-06-2005
Location: Eugene, Oregon USA
Posts: 162
Status: 
Offline
The reservoir is supposed to serve both circuits, so you just have to fill it full to the top.  In the original TR application, the MC is angled so that the top of the reservoir is level, and that's why it looks so goofy in the JH.  I've only seen one JH with the original MC, out of the ~30 or so that I've seen, so this TR unit must work fine.  I haven't had any problems with mine since installation.  IIRC, the rear reservoir feeds the front brakes, so it has to be larger to accomodate the greater change in volume as the disc pads wear and the caliper pistons move to accomodate them.  The pistons in the drums are much smaller diameter, so they won't need as much fluid when they auto-adjust.  And if you have the manual adjust drums, they don't use any fluid, since the adjustment is made on the other side from the pistons.  That's why the reservoirs are so different in size, I think.

To get the PDWA to shut off, you have to have one person release the bleeder while another applies firm pressure to the pedal.  When the light goes off, the pedal pusher must shout to the bleeder operator to close the screw, lest the switch go too far and illuminate the bulb again. In an ideal world, the PDWA would have a built-in return spring, so it would only go off while there was currently a pressure differential.  Not so: it simply records that there was a difference.  By opening the bleeder screw and applying pressure, you're trying to shuttle the little switch back to the middle, null, setting. 

I rebuilt my PDWA, you know, and it immediately started leaking out the electrical connector at the top.  So I did like Mark suggested so long ago, and I plugged it up with an appropriate bolt.  Now it doesn't leak and the light doesn't go off, either.  Eventually I'm going to do like Judson (I think?) suggested, and get the inside of the thing plugged up, so fluid can't leak across in the event of a failure.  I might even make all new stainless brake lines and get rid of the PDWA entirely. 

Back To Top PM Quote Reply  

 Posted: 06-04-2008 02:20 am
  PM Quote Reply
22nd Post
LambandAndy
Member


Joined: 10-21-2005
Location: Eastanollee, Georgia USA
Posts: 72
Status: 
Offline
I managed to reset mine by removing the switch and using something like a ball end allen wrench (don't remember exactly) in the indent in the piston, pull it back to center.

Andy

Back To Top PM Quote Reply

 Posted: 06-04-2008 04:23 pm
  PM Quote Reply
23rd Post
Jay
Member


Joined: 08-05-2005
Location: Canton, Ohio USA
Posts: 73
Status: 
Offline
Andy,

Something like that is what I thought may be worth a try. I was hoping someone may have already tried this. Thanks for the tip. With the switch removed I should be able to see which way the piston needs to move rather than guessing. I'll give that a try.

Jay


UPDATE:

Andy,

My PDWA must be different than yours. When I remove the switch, all that is revealed is a small steel ball that now appears to be in the up position to depress the switch plunger. The mechanism to move the ball (a groove or taper in the pistons) is not revealed. It appears that I will need to resort to the bleeding procedure to reset my switch. It is interesting to note that the ground path to the switch plunger is by way of a small spiral spring on the tip of the switch plunger. After tweeking this spring, I find that the tail of the spring needs to be positioned so that it contacts the ID of the threaded switch bore. Upon removal of the switch the spring got a little distorted.

I removed the switch, and when it looked like I wouldn't be able to reset the switch by going this route, I screwed the switch back in and reconnected the wire. My warning light was now off! I wondered how the switch could reset itself, but when I investigated futher I realized that it didn't. It just was not getting grounded through the little spring. That is when I deflected the tail of the spring outward so it would contact the bore. To complete the ground circuit the spring needs to contact the housing and the switch plunger nedds to be depressed.

I found the following reference from the old board to be helpful.

Jay

http://www.jensenhealey.com/msgboard.mv?parm_func=showmsg+parm_msgnum=1008604

Last edited on 06-05-2008 02:24 pm by Jay

Back To Top PM Quote Reply  

Current time is 03:49 am Page:  First Page Previous Page  1  2     
> Jensen Healey & Jensen GT Tech > Brakes > Brake light on after hose replacement Top




UltraBB 1.172 Copyright © 2007-2011 Data 1 Systems