Home 

 Moderated by: Greg Fletcher  
AuthorPost
Ty Hisatomi
Member
 

Joined: 05-08-2006
Location: Ashland, Oregon USA
Posts: 5
Status: 
Offline
It's happened twice now so I better get her up on jack stands and check it out.......when braking fairly hard, my front passenger side brakes seems to be locking up, enough to initiate a skid and squeal!  The brake always releases so I'm guessing it's in the calipers, that they're not braking evenly and are grabbing big time.  The driver's side doesn't seem to have the problem, except both sides seem to be tighter than usual and the disk doesn't exactly spin freely as on would expect.  I'm told that this happens when folks allow their Jensen to sit for awhile I don't get driven as much as it should.  Since I live in snow country, unfortunately, that's what happens. Right off the bat I'm thinking that I should rebuild the calipers.  

That's where I'm going unless there are some other pearls of wisdom out there.  Any advice is welcomed.

Last edited on 09-14-2008 12:15 am by Ty Hisatomi

Ron Mau
Member
 

Joined: 03-14-2005
Location: Davenport, Iowa USA
Posts: 61
Status: 
Offline
Hi,

Sometimes the brake hoses age and swell up on the inside not releasing the pressure. If you hven't replaced them in along time it might be your problem. I'd look at the calipers also, a good cleaning won't hurt a bit. Replacing all the rubber parts will be good insurance.

 

Ron Mau

Greg Fletcher
Administrator


Joined: 03-11-2005
Location: Lake Nacimiento, California USA
Posts: 421
Status: 
Offline
As a maintenance thing, I would replace the hoses and rebuild both front calipers before driving it again. That kind of symptom indicates that the brake system has been neglected. Better to fix it immediately and not risk a potentially dangerous situation to occur.

Jensen Healey
Super Moderator


Joined: 03-11-2005
Location: San Anselmo, California USA
Posts: 976
Status: 
Offline
I had the same issue after replacing the hoses. Repeatedly and carefully bleeding the system did the trick.

The bleed screws leak around the threads when open so using bleed valves wasn't working too well. A but of heavy grease on the threads kept the air out until I closed the screws. Good Luck

Kurt



UltraBB 1.172 Copyright © 2007-2011 Data 1 Systems