Home 

 Moderated by: Greg Fletcher  
AuthorPost
Frank Schwartz
Guest
 

Joined: 
Location:  
Posts: 
Status: 
Offline
i wonder if anyone has had any experience with the front camshaft oil seal leaking.  We are getting a bit of oil being slung up on the underside of the hood.  Sealed the cam covers with Permatex and do not seem to have any leakage there. 
On an old engine we have for comparison,  I can see the oil seal in the front around the shaft with the toothed wheel removed.  So... has anyone had experience with this problem and if so, can they tell me  how to remove the oil seal in the front and replace it without disassembling the entire camshaft assembly?

Jim Ketcham
Member
 

Joined: 03-13-2005
Location: Salt Point, New York USA
Posts: 192
Status: 
Offline
Hello Frank,

I have had problems with the new aux. housing seal and front cover seals that come in the gasket kits from Delta and found that they were not optimally sized.  If your leak is indeed the cam tower seal you should be able to finess a new one in without pulling the tower.  You should be able to get the old one out with a seal puller.  Install new one with lip well lubed and, if I recall correctly, a 2'' pipe coupling fit over the cam and allowed pressing in the new seal FLUSH.  DO NOT press in beyond the face being flush as you will block the oil feed hole.  Good luck.

Frank Schwartz
Guest
 

Joined: 
Location:  
Posts: 
Status: 
Offline
Sounds easy enough, Jim.  The two inch pipe coupling you spoke of is just a piece of pipe you use to tamp the thing in place...right?
I will borrow a seal puller from a mechanic friend and give it a try.  
I wonder if the seal is a generic one I can obtain locally...or only from Delta?  And do you know the "specs" on the seal.  Probably will change both while I am at it...merely as a precaution.    Thank you  for the information.

Jensen Healey
Super Moderator


Joined: 03-11-2005
Location: San Anselmo, California USA
Posts: 977
Status: 
Offline
The bolt that holds on the pulley needs to be sealed. It has full oil pressure behind it.

Kurt

Jim Ketcham
Member
 

Joined: 03-13-2005
Location: Salt Point, New York USA
Posts: 192
Status: 
Offline
Actually, the bolt that holds the pulley should have no pressure on it.  There should be an allen screw plug that screws and seats into the cam thus sealing the oil passage before it gets to the pulley bolt.  The allen screw plug should be sealed.  For Frank's application, it is not necessary to remove so he should have no problem.

Second thought, should check that the plug is in place by sticking a wire into the bolt hole.  It seats approximately 2 inches in (just shy of the oil feed hole). 

Jensen Healey
Super Moderator


Joined: 03-11-2005
Location: San Anselmo, California USA
Posts: 977
Status: 
Offline
Thanks for the correction Jim! I checked a spare camshaft and indeed it did have the plug. Now I need to remove the bolts from the pulleys and check there. I suspect the intake side is missing the plug.

Kurt


Edit: Plug is there, but it leaks!

Last edited on 05-26-2008 07:56 pm by Jensen Healey



UltraBB 1.172 Copyright © 2007-2011 Data 1 Systems