Home 
Home Search search Menu menu Not logged in - Login | Register

 Moderated by: Greg Fletcher
New Topic Reply Printer Friendly
Meltdown!  Rate Topic 
AuthorPost
 Posted: 02-18-2008 02:59 am
  PM Quote Reply
1st Post
mcguan.2
Member
 

Joined: 12-13-2007
Location:  
Posts: 42
Status: 
Offline
OK, so I hooked up my rebuilt alternator on my '76 GT and then went to hook up the battery.  I hooked up the negative first and then the positive.  Once the positive was securely on the terminal, I had a complete Lucas-style electrical meltdown, complete with smoke and glowing red wires.  What the hell happened?  Anyone?

I got the alternator on ebay, rebuilt.  It had two larger spades stamped + and -, and the previous owner (of the GT) was kind enough to label one of the cables with red tape, so I'm pretty sure I had positive to positive and negative to negative. There were two other wires, but one was bent back and taped against the bundle, so I was pretty sure I wouldn't need it.  The remaining wire with a smaller spade I hooked to the "ind" spot, presumably for indicator lights.  So, all in all, everything on that end seemed to be hunky-dory. 

But, as I said, as soon as the positive cable was on the terminal, I had fourth of july fireworks.  I fried all the wiring from the alternator to just past the battery (but not all the way to the harness connector coming out of the distributor).  So, two questions, what happened and how hard is it going to be for me to rebuild all that wiring and catch the mistake so that it doesn't happen again?

Back To Top PM Quote Reply  

 Posted: 02-20-2008 04:50 pm
  PM Quote Reply
2nd Post
Greg Fletcher
Administrator


Joined: 03-11-2005
Location: Lake Nacimiento, California USA
Posts: 421
Status: 
Offline
"The previous owner said" blah, blah, blah. That's always a cause for concern. I would, at the very least, triple check whatever Previous Owner tells you and assume everything is false until proven otherwise.

Your post is missing quite a bit of info, was this the stock Lucas alternator? What model #? What happened to your plug on the harness that goes to the alternator? This should plug into the new unit the same way (thus avoiding misconnection issues). Actually nothing on the alternator goes to "indicator lights". This part of your message scares me.

To sort this out, you'll ned to replace ALL the burned wiring with correct gauge and color (it's not that hard to find). I'd start by opening up the harness and checking everything very carefully one wire at a time, sometimes wires are burned or have melted insulation and it's hard to see. I think you can most likely write off the current alternator, so I'd be looking for a stock unit that has the proper connections already installed.

The charging system on the stock cars is really very reliable and will remain so if the alternators are rebuilt correctly (usually that's not the case). Yes, you will pay more for a properly remanufactured alternator, but I find that it's money well spent. You can always convert to a US made Delco alternator. The early JH's came with a English Delco unit, which is not the same inside, but, again, properly remanufactured units will be very reliable.

Back To Top PM Quote Reply

Current time is 11:34 am  
> Jensen Healey & Jensen GT Tech > Electrical & Instruments > Meltdown! Top




UltraBB 1.172 Copyright © 2007-2011 Data 1 Systems